Draft Approval

Incident Report for Public Pulse

Resolved

This incident has been resolved.
Posted Apr 05, 2026 - 08:04 UTC

Update

Members of Parliament were temporarily unable to approve email drafts through the approval workflow. The issue was identified and a fix was deployed. All approval functionality has been restored.
Posted Apr 05, 2026 - 08:04 UTC

Identified

Members of Parliament were temporarily unable to approve email drafts through the approval workflow.
Posted Apr 05, 2026 - 08:03 UTC
This incident affected: PulseAi (Pulse Drafting).